近几天打算用Docker跑一个需要PHP5.6的项目,然后发现Docker官方提供的PHP镜像中,只有PHP7.0以上的介绍。没有PHP5.5及PHP5.6的(tag还有,只不过主页中没有) 感到比较纳闷,官方github也移除了相关的代码。 搜索发现原来是PHP官方团队已经不再维护5.6。 也就是说,既然官方都不管了,Docker更不没有必要继续维护相关分支。 然后去PHP官方公告查看从2019年1月1日起PHP5.6已经不再维护支持,就连PHP7.1都只进行安全支持。

image.png

这样可以倒逼企业进行系统版本更新换代。对开发人员绝对是好事,虽然企业主出于成本考虑不愿意进行升级。 最后如果想查看之前5.6及5.5的Dockerfile细节,可以查看这个PR

上次更新: 9/8/2019, 5:47:49 PM